Problème avec Array

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
Daydreamer057
Niveau 1
Niveau 1
Messages : 1
Enregistré le : jeu. 05 mars 2020 01:30
Status : Hors ligne

Problème avec Array

#1

Message par Daydreamer057 »

Bonjour
j'ai un problème de programmation d'array.
J'ai le code

Code : Tout sélectionner

Global $firstSkill[4]

init()

Func init()
	$firstSkill[0] = True
	$firstSkill[1] = True
	$firstSkill[2] = True
	$firstSkill[3] = True
EndFunc
J'ai l'erreur suivante au lancement :
Expected a "=" operator in assignment statement.
$firstSkill[$k] = True
$firstSkill^ ERROR

Si je met le code suivant ça fonctionne :

Code : Tout sélectionner

Global $firstSkill[4]
$firstSkill[0] = True
$firstSkill[1] = True
$firstSkill[2] = True
$firstSkill[3] = True
Pourquoi il y a une erreur quand on utilise une fonction ?
Merci pour vos réponses.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11510
Enregistré le : ven. 20 juil. 2007 21:00
Localisation : Bordeaux
Status : Hors ligne

Re: Problème avec Array

#2

Message par Tlem »

Bonjour.
Êtes vous sur d'utiliser la dernière version d'AutoIt car en ce qui me concerne, SciTE4AutoIt ne me retourne aucune erreur ?
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 749
Enregistré le : ven. 12 août 2011 19:49
Localisation : Essonne
Status : Hors ligne

Re: Problème avec Array

#3

Message par walkson »

Bonjour,
Quand je lis $firstSkill[$k] = True, je me demande d'où vient la variable $k ??? :shock:
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi
(Je ne compte que les heures heureuses)

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11510
Enregistré le : ven. 20 juil. 2007 21:00
Localisation : Bordeaux
Status : Hors ligne

Re: Problème avec Array

#4

Message par Tlem »

AMHA dans le code original de la fonction init() il devait sans doute y avoir une boucle For/Next. ^^
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

Répondre