Problème boutons

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
Lilian360
Niveau 1
Niveau 1
Messages : 6
Enregistré le : jeu. 28 févr. 2019 20:07
Status : Hors ligne

Problème boutons

#1

Message par Lilian360 » lun. 03 juin 2019 20:46

Bonjour,

Excusez moi pour ces deux messages dans la même soirée...

J'ai un nouveau problème:

Quand on appui sur le Button de ma GUI ($Form1), ça appelle (Call) une fonction qui contient
une nouvelle GUI ($Form2) qui sert à paramétrer mon application. J'ai fait en sorte que quand on ferme:
Case $GUI_EVENT_CLOSE

                GUISetState(@SW_HIDE)
Ce code est dans une nouvelle While pour la Form2 ce qui fait qu'il y a deux While, dîtes moi si c'est inutile.

Cependant, une fois cette GUI ($Form2) est fermé plus aucun bouton de la Form1 ne marche...

Y a t-il une solution ?

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 694
Enregistré le : ven. 12 août 2011 18:49
Localisation : Essonne
Status : Hors ligne

Re: Problème boutons  

#2

Message par walkson » mar. 04 juin 2019 00:01

Qui a écrit
Informations insuffisantes, mais à vue de nez je suggérerais de....
et bien rebelote :shock:
dîtes moi si c'est inutile.
ça dépend du code :P
plus aucun bouton de la Form1 ne marche
c'est que la boucle sur Form2 continue à tourner (enfin, je devine :roll: ) donc il faut Exitloop pour sortir de la boucle Form2 pour revenir à la boucle Form1
Concernant les problèmes de boutons, je vous conseille de consulter un pharmaciens :lol:
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi

Lilian360
Niveau 1
Niveau 1
Messages : 6
Enregistré le : jeu. 28 févr. 2019 20:07
Status : Hors ligne

Re: Problème boutons

#3

Message par Lilian360 » mar. 04 juin 2019 05:45

Effectivement vous avez vu juste, merci pharmacien Walkson ! :D

Avatar du membre
TommyDDR
Modérateur
Modérateur
Messages : 1808
Enregistré le : mar. 22 juil. 2008 20:55
Localisation : Nantes
Status : Hors ligne

Re: Problème boutons

#4

Message par TommyDDR » mar. 04 juin 2019 08:59

Je propose aux modérateurs et à tout membre de ce forum de répondre :
"Article 27 du 04/06/2019 : Merci de fournir un code fonctionnel reproduisant le problème."
Lorsque le demandeur ne fourni pas assez d'informations et que nous devons spéculer pour la énième fois.
3.1415926535897932384626433832795028841971693993751058209749445923078164062862089986280348253421170679

Lilian360
Niveau 1
Niveau 1
Messages : 6
Enregistré le : jeu. 28 févr. 2019 20:07
Status : Hors ligne

Re: Problème boutons

#5

Message par Lilian360 » mar. 04 juin 2019 15:05

Je suis contre, si les informations que j'ai fournis n'auraient pas été suffisantes, les bons modérateurs de ce forum n'aurait pas su trouver la solution.
Ce qui ici n'est pas le cas, il a tout à fait su répondre à ma demande d'aide avec humour et rapidité.

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 694
Enregistré le : ven. 12 août 2011 18:49
Localisation : Essonne
Status : Hors ligne

Re: Problème boutons

#6

Message par walkson » mar. 04 juin 2019 22:06

Je partage totalement l'avis de TommyDDR car répondre en imaginant tous les problèmes possibles c'est franchement lassant alors qu'un simple code permet de voir le problème immédiatement (et de le résoudre)
Merci d'en tenir compte dans vos prochaines demandes !
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi

Répondre