icone disparais au déplacement de l'exe

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
yohanb767
Niveau 5
Niveau 5
Messages : 115
Enregistré le : mer. 28 déc. 2016 14:09
Status : Hors ligne

icone disparais au déplacement de l'exe

#1

Message par yohanb767 »

bonjour a tous !

j'aimerai ajouter un icone sur mon script une fois compilé , j'ai lu pas mal de chose sur le forum à ce sujet mais je n'ai trouver pour m'éclairer
j'arrive à bien ajouter un icone sur mon script une fois compilé mais quand je déplace l'.exe l'icone disparais si il n'est pas dans le dossier ou ce trouve le .ico ce qui évident
j'aimerai juste savoir comment faire pour qu'en déplacent l'exe l'icone ne disparaisse pas

voici un morceau de mon script et ce que j'ai ajouter pour le .ico

Code : Tout sélectionner

#region Variable Global hors Interface

Global $hListView

#endregion

#pragma compile(Icon,C:\MO\SE\SAV\SAV_TSNG\Litige\Icons\Ico.ico)

#region Interface Menu
; ####################################### Début de la création de l'interface Menu ########################################################
Global $F_Menu = GUICreate("Gestion des Litiges - v1.0.0", 565, 213, 192, 124)
Global $Pic1 = GUICtrlCreatePic(@ScriptDir &"\Icons\Fond.jpg", 0, 0, 565, 213)

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 740
Enregistré le : ven. 12 août 2011 19:49
Localisation : Essonne
Status : Hors ligne

Re: icone disparais au déplacement de l'exe

#2

Message par walkson »

Bonjour,
Avez vous essayé de compiler (ctrl + F7) et de choisir le chemin de l'Icon. Ça devrait résoudre le problème
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi
(Je ne compte que les heures heureuses)

yohanb767
Niveau 5
Niveau 5
Messages : 115
Enregistré le : mer. 28 déc. 2016 14:09
Status : Hors ligne

Re: icone disparais au déplacement de l'exe

#3

Message par yohanb767 »

Bonjour Walkson

dans Scite avec (Ctrl+F7) cela me compile bien mon script mais aucune option pour l'icone pour le chemin
ma version de scite est elle en cause ? Version 3.5.4

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 740
Enregistré le : ven. 12 août 2011 19:49
Localisation : Essonne
Status : Hors ligne

Re: icone disparais au déplacement de l'exe  

#4

Message par walkson »

Image124703.jpg
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi
(Je ne compte que les heures heureuses)

yohanb767
Niveau 5
Niveau 5
Messages : 115
Enregistré le : mer. 28 déc. 2016 14:09
Status : Hors ligne

Re: icone disparais au déplacement de l'exe

#5

Message par yohanb767 »

Non désolé quand je fait "Ctrl + F7" ca ne m'ouvre pas cette fenêtre

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 740
Enregistré le : ven. 12 août 2011 19:49
Localisation : Essonne
Status : Hors ligne

Re: icone disparais au déplacement de l'exe

#6

Message par walkson »

Dans la barre de Scite, cliquez sur Outils puis Compiler
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi
(Je ne compte que les heures heureuses)

yohanb767
Niveau 5
Niveau 5
Messages : 115
Enregistré le : mer. 28 déc. 2016 14:09
Status : Hors ligne

Re: icone disparais au déplacement de l'exe

#7

Message par yohanb767 »

Merci Walkson , en faite ma version n'était pas bonne merci.

Répondre