[V] Création d'un BotSpammer

Aide sur les Interfaces Graphique Utilisateurs (GUI).
Règles du forum
.
Verrouillé
SirZokxyron
Niveau 1
Niveau 1
Messages : 3
Enregistré le : mar. 28 févr. 2017 14:51
Status : Hors ligne

[V] Création d'un BotSpammer

#1

Message par SirZokxyron »

Bonjour!

Je me suis lancé depuis peu dans la programmation AutoIt, et je m'améliore en me donnant de petit objectifs ! Cependant, j'ai actuellement besoin d'aide car je ne comprend pas comment réaliser ce que je souhaite faire !

Pour vous dire voilà le code qui me pose en parti problème :
While 1
   $nMsg = GUIGetMsg()
   Switch $nMsg
      Case $GUI_EVENT_CLOSE
         Exit
      Case $ExitSpam
         Exit
      Case $SpamON
         $TextToSpam = GUICtrlRead ($WhatToSpam)
         Sleep (250)
         Send ("{ALTDOWN}")
         Sleep (250)
         Send ("{TAB}")
         Sleep (250)
         Send ("{ALTUP}")
         Sleep (250)
         $SpamSwitch = 1
      Case $SpamOFF
         $SpamSwitch = 0
   EndSwitch
   If GUICtrlRead ($SpamSpeedSelector) = 0 Then
      $SpamSpeed = 1000
   Else
      If GUICtrlRead ($SpamSpeedSelector) = 1 Then
         $SpamSpeed = 500
      Else
         If GUICtrlRead ($SpamSpeedSelector) = 2 Then
            $SpamSpeed = 250
         Else
            If GUICtrlRead ($SpamSpeedSelector) = 3 Then
               $SpamSpeed = 100
            Else
               $SpamSpeed = 50
            EndIf
         EndIf
      EndIf
   EndIf
   If $SpamSwitch = 1 Then
      Send ($TextToSpam)
      $HowMuchSpammed = $HowMuchSpammed + 1
      GUICtrlSetData ($HowMuchSpammedView, $HowMuchSpammed)
      If GUICtrlRead ($PressEnter) = 1 Then
         Send ("{enter}")
      Else
      EndIf
      Sleep ($SpamSpeed)
   ElseIf $SpamSwitch <> 2 Then
      MsgBox (262144 & 0 & 64, "SpamBot", "Spam has ended")
      $SpamSwitch = 2
   EndIf
WEnd
Tout est fonctionnel, l'interface graphique fonctionne bien, mais ! Je n'arrive pas à faire fonctionner le bouttons SpamOFF, ni le bouttons EXITSpam quand $SpamSwitch = 1 c'est à dire que le spam est en marche.

Selon vous quelle serait mon erreur ?
Merci de votre réponse.

(Si jamais je dois ajouter d'autre renseignements dites le moi.)
Avatar du membre
parazitenew
Niveau 7
Niveau 7
Messages : 310
Enregistré le : sam. 10 déc. 2011 15:08
Localisation : Algerie
Contact :
Status : Hors ligne

Re: [..] Création d'un BotSpammer

#2

Message par parazitenew »

Bonjour, tout ce qui se rapporte aux bots est interdit par le règlement du forum.
Avatar du membre
orax
Modérateur
Modérateur
Messages : 1479
Enregistré le : lun. 23 mars 2009 04:50
Localisation : ::1
Contact :
Status : Hors ligne

Re: [..] Création d'un BotSpammer

#3

Message par orax »

De petits détails peuvent faire toute la différence. — Quand la boule de neige commence à rouler… poussez-la. (Columbo)
Verrouillé