Icon sur Exe

Aide sur les Interfaces Graphique Utilisateurs (GUI).
Règles du forum
.
Répondre
liberodark
Niveau 4
Niveau 4
Messages : 73
Enregistré le : jeu. 20 août 2015 20:33
Status : Hors ligne

Icon sur Exe

#1

Message par liberodark » sam. 30 juil. 2016 18:35

Bonjour,

J'ai un question comment on peut faire pour avoir une icon sur un exe ?
Quand on compile avec autoit.

Cordialement

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11297
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Icon sur Exe

#2

Message par Tlem » sam. 30 juil. 2016 18:39

Heuuu, vous n'avez même pas fait une petite recherche sur le forum !!!
Franchement c'est pas cool.
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

liberodark
Niveau 4
Niveau 4
Messages : 73
Enregistré le : jeu. 20 août 2015 20:33
Status : Hors ligne

Re: Icon sur Exe

#3

Message par liberodark » sam. 30 juil. 2016 18:47

Si j'ai fait une recherche mais il y avait ce que je cherche, j'ai surement mal fait la recherche je vais voir.

liberodark
Niveau 4
Niveau 4
Messages : 73
Enregistré le : jeu. 20 août 2015 20:33
Status : Hors ligne

Re: Icon sur Exe

#4

Message par liberodark » sam. 30 juil. 2016 19:07

Voici mon erreur une fois compilé mes icons ne sont plus présentes.
Et je souhaite quel soit intégré dans la compilation.
$hMainGUI = GUICreate("Launcher SSE", $iW, $iH, -1, 150)
GUISetIcon("steam.ico", -58, $hMainGUI)
GUICtrlCreateLabel("Open Source Launcher 2.1.0 Build 1", 48, 8, $iW - 56, 32, $SS_CENTERIMAGE)
GUICtrlSetFont(-1, 14, 800, 0, "Arial", 5)
GUICtrlCreateIcon("steam.ico", -131, 8, 8, 32, 32)
GUICtrlCreateLabel("", 0, $iT, $iW, 2, $SS_SUNKEN) ; separator
GUICtrlCreateLabel("", $iLeftWidth, $iT + 2, 2, $iH - $iT - $iB - 2, $SS_SUNKEN) ; separator
GUICtrlCreateLabel("", 0, $iH - $iB, $iW, 2, $SS_SUNKEN) ; separator
$hFooter = GUICtrlCreateLabel("© 2016 liberodark", 10, $iH - 18, $iW - 20, 17)
GUICtrlSetTip(-1, "GitHub", "Click to open...")
GUICtrlSetCursor(-1, 0)

$intro1 = GUICtrlCreateIcon("open.ico", -131, $iLeftWidth + 100, 100, 64, 64)
$intro2 = GUICtrlCreateLabel("Welcome", $iLeftWidth + 95, 180, 100, 25)
GUICtrlSetFont(-1, 14, 800, 0, "Arial", 5)
Cordialement

GUICtrlSetImage($Icone_Cadenas, @ScriptFullPath, 201)
#pragma compile(Icon, C:\Program Files (x86)\AutoIt3\Icons\au3.ico)

J'ai trouvé ceci sur votre forum mais j'ai du faire une erreur car cela ne fonctionne pas.
Sinon j'ai trouvé un fileinstall mais il y pas d'autres moyens pour l'intégré à la compilation ?

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11297
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Icon sur Exe

#5

Message par Tlem » sam. 30 juil. 2016 19:45

#pragma compile(Icon, C:\Program Files (x86)\AutoIt3\Icons\au3.ico) est la bonne commande.

Il faut mettre le bon chemin vers votre icône et avoir la dernière version d'AutoIt.
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

Avatar du membre
orax
Modérateur
Modérateur
Messages : 1454
Enregistré le : lun. 23 mars 2009 04:50
Localisation : ::1
Contact :
Status : Hors ligne

Re: Icon sur Exe  

#6

Message par orax » sam. 30 juil. 2016 20:04

Ça peut aussi se faire depuis le menu Tools > Compile ou CTRL+F7.
De petits détails peuvent faire toute la différence. — Quand la boule de neige commence à rouler… poussez-la. (Columbo)

liberodark
Niveau 4
Niveau 4
Messages : 73
Enregistré le : jeu. 20 août 2015 20:33
Status : Hors ligne

Re: Icon sur Exe

#7

Message par liberodark » sam. 30 juil. 2016 20:38

Géniale je vais voir cela :D
C'est parfait moi je fait tout le temps clic droit pour compiler maintenant ce sera CTRL + F7 ^^
Maintenant j'ai une icon sur mon Exe c'est top.
Mais j'ai bien ajouté les icons mais cela n’apparaît pas dans mon logiciel une fois compilé
Il y a un changement a faire ?

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11297
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Icon sur Exe

#8

Message par Tlem » sam. 30 juil. 2016 23:53

La question originale concernait l'icône sur l'exe compilé ! :roll:

Là vous rajoutez un élément supplémentaire. :mrgreen:
Pour les icônes ou logo sur l'interface graphique de votre programme, il faut adopter une autre solution.

3 choix :
  • - Le facile : On rajoute les images avec la commande FileInstall(). Cette commande permet d'inclure lors de la compilation, divers fichiers qui seront tout simplement extrait vers un dossier déterminé lorsque la commande sera exécutée. Ensuite il suffit d'utiliser les commandes idoines et de choisir l'une des images du dossier spécifié.

    - Le moins facile : On rajoute les images en tant que ressources dans l’exécutable lors de la compilation avec des commandes spécifiques et ensuite on utilise des commandes venant de l'UDF ResourceEx.au3 pour extraire directement sans passer par un fichier externe les différentes ressources.

    - Pas plus facile : La DLL de ressources. On crée une DLL qui contient images, texte, son, etc ... et on utilise le même UDF que ci-dessus.
Je vous conseil de lire les tutos concernant l'utilisation des ressources :
Ajout et utilisation de ressources dans votre EXE
Création d'une dll de ressources pour votre script
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

liberodark
Niveau 4
Niveau 4
Messages : 73
Enregistré le : jeu. 20 août 2015 20:33
Status : Hors ligne

Re: Icon sur Exe

#9

Message par liberodark » dim. 31 juil. 2016 00:31

Merci beaucoup je vois le problème et donc oui je préfère évité le fileintall mais en plus ce qui est bizzare c'est que j'ai déjà ajouté les images et j'en est une qui est resté sur mon GUI mais deux que non.
Donc mon soucis de base est résolu je vais faire alors un nouveau sujet :D

Cordialement

Répondre