Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

Forum de promotion sur des outils créés pour AutoIt
Avatar du membre
DJSIR
Niveau 8
Niveau 8
Messages : 583
Enregistré le : mar. 01 juil. 2008 14:16
Localisation : 76, Le HAVRE (in the DJSIR World)
Contact :
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#21

Message par DJSIR » mar. 29 juin 2010 17:26

Je pense que Tlem le sait étant donné qu'il à fait le pack.
$DJSIR = "1000110001010101011010000101001101001101001010101011010"
(ne décodez pas le binaire, ça veux rien dire)

[Func] ProgressBar, aller plus loin

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#22

Message par Tlem » mar. 29 juin 2010 21:52

Image

.

Avatar du membre
freMea
Niveau 1
Niveau 1
Messages : 8
Enregistré le : mar. 16 nov. 2010 03:57
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#23

Message par freMea » mar. 16 nov. 2010 04:06

Salut,

Suis nouveau, je débute dans la programmation en générale, et j'ai une question :wink: :

J'ai AutoIt v3.3.6.1 et XP PRO SP3 et j'ai remarqué que, pour l'instant, tout était bien francisé comme les MsgBox. Cependant, les inputbox ne le sont pas
Image

Est-ce pareil chez vous ?
- Ultra débutant (noob, nulos...) en programmation
- AutoIt v3.3.6.1
- XP PRO SP3
- Processeur: Intel Mobile Core 2 Duo T5200 @ 1.60GHz
- RAM: 2.0 Go Canal-Double DDR2 @ 266 MHz (4-4-4-12)
- Graphique: 256 MoNVIDIA GeForce Go 7300 (Toshiba)

Avatar du membre
bloodwolff
Membre émérite
Membre émérite
Messages : 655
Enregistré le : ven. 18 avr. 2008 21:36
Localisation : Québec
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#24

Message par bloodwolff » mar. 16 nov. 2010 04:53

Sur ton image l'input est en français :shock:
Compte skype : bloodwolfff

Avatar du membre
freMea
Niveau 1
Niveau 1
Messages : 8
Enregistré le : mar. 16 nov. 2010 03:57
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#25

Message par freMea » mar. 16 nov. 2010 04:58

"Cancel", c'est français pour toi? :D

Sur mes MsgBox, le bouton est bien traduit par "Annuler", alors pourquoi pas pour les InputBox.
- Ultra débutant (noob, nulos...) en programmation
- AutoIt v3.3.6.1
- XP PRO SP3
- Processeur: Intel Mobile Core 2 Duo T5200 @ 1.60GHz
- RAM: 2.0 Go Canal-Double DDR2 @ 266 MHz (4-4-4-12)
- Graphique: 256 MoNVIDIA GeForce Go 7300 (Toshiba)

Avatar du membre
bloodwolff
Membre émérite
Membre émérite
Messages : 655
Enregistré le : ven. 18 avr. 2008 21:36
Localisation : Québec
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#26

Message par bloodwolff » mar. 16 nov. 2010 05:05

Je suis habituer d'utiliser les 2 langues et j'étais sûr que cancel était français :lol:
Désolé , Si tu y tiens je peux te faire une fonction identique à inputbox mais qui créera les boutons en français
Là il commence à être tard (23h04) donc je te ferai sa demain dans la journée
Compte skype : bloodwolfff

Avatar du membre
freMea
Niveau 1
Niveau 1
Messages : 8
Enregistré le : mar. 16 nov. 2010 03:57
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#27

Message par freMea » mar. 16 nov. 2010 08:01

Merci.

Pour l'instant, te prends pas la tête. Je suis en train d'explorer les différents UDF sur les forums. Il y aura surement parmi celles-là des InputBox que je pourrais modifier. Je reviendrai vers toi si besoin.

Bonne nuit ou journée
- Ultra débutant (noob, nulos...) en programmation
- AutoIt v3.3.6.1
- XP PRO SP3
- Processeur: Intel Mobile Core 2 Duo T5200 @ 1.60GHz
- RAM: 2.0 Go Canal-Double DDR2 @ 266 MHz (4-4-4-12)
- Graphique: 256 MoNVIDIA GeForce Go 7300 (Toshiba)

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#28

Message par Tlem » mar. 16 nov. 2010 08:21

Bonjour.

En ce qui concerne les InputBox, il me semblait déjà l'avoir signalé aux développeurs !!! Mais après quelques recherches, je n'ai rien retrouvé. :shock:
Donc je vais rajouter un message dans le bugtrac.

Merci.

Edit : C'est fait (ou re-fait) : http://www.autoitscript.com/trac/autoit/ticket/1814

Avatar du membre
eln
Niveau 6
Niveau 6
Messages : 202
Enregistré le : sam. 28 juil. 2007 11:54
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

#29

Message par eln » mer. 26 janv. 2011 18:12

Juste pour signaler que si on veux changer le répertoire d'installation, ça reste par défaut sur "C:\Program Files (x86)\AutoIt3" sur Seven. J'ai remarqué la même chose avec le répertoire d'installation par défaut sur XP.
Après bien sur on peut rentrer le chemin à la main mais dans ce cas là le FileSelectFolder ne sert à rien à part créer un dossier. :mrgreen:

Sinon toujours du très bon travail. :wink:
Débutant, pas taper !

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#30

Message par Tlem » mer. 03 août 2011 15:10

Mise à jour du pack :
  • - Mise à jour AutoIt v3.3.6.1.
    - Mise à jour Scite4AutoIt du 03-07-2011.
    - Mise à jour de Koda v1.7.3.0 + traduction Française.
    - Mise à jour de SandBoxie 3.56.0.0.
    - Modification du comportement de la sélection du répertoire d'installation.
Depuis le mois de Janvier, je ne m'était pas penché sur ce problème de sélection de dossier.
En fait, j'avais tout simplement oublié de reprendre le code de cette partie ... :oops:

Dans cette mise à jour, j'ai remarqué un bug sur la mise à jour de SandBoxie, dons si vous ne voulez pas avoir de problème, désinstallez votre version de SandBoxie, ou décochez la case. ;)

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#31

Message par Tlem » jeu. 11 août 2011 15:58

Il semble que dans l'installateur Scite4AutoIt3 du 03/07/2011, il y ai un problème avec l'utilitaire CSnippet.exe qui retourne un message d'erreur sur Windows Seven et peut être sur d'autres versions de Windows.
Pour résoudre le problème, allez dans le dossier C:\Program Files\AutoIt3\SciTE\cSnippet, supprimez l'exécutable, puis recompilez-le grâce au fichier CSnippet.au3 (Clic de droite sur le fichier, puis "Compiler le Script").

perfaram
Niveau 4
Niveau 4
Messages : 68
Enregistré le : jeu. 28 avr. 2011 10:40
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#32

Message par perfaram » ven. 26 août 2011 16:51

Bonjour,
Je suis en train d'essayer de mettre une nouvelle interface graphique au Pack, en me basant sur celle de LiliUSB Creator, et sur le système de notification à l'adresse http://www.autoitscript.fr/forum/viewto ... tification, qui informerait de chaque étape, en lieu et place des gros splashs blancs qui cache l'écran.
Or quand j'extrais le fichier au3 du pack-autoit-fr.exe, et que j'essaye de l'exécuter, il demande plusieurs Includes "exotiques" comme 7zip.au3 et ImportedFunctions.au3. Je voudrais savoir où les trouver car elles ne sont pas présentes dans le pack.

EDIT : J'ai fini par trouver sur internet 7zip.au3, mais pas l'autre car j'imagine qu'il a été réalisé pour l'occasion.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#33

Message par Tlem » ven. 26 août 2011 21:51

Le dernier pack est un simple fichier zip contenant AutoIt.exe et les scripts d'installation. Bref tout y est inclu tout simplement (et c'est voulu).
Je suis aussi plus ou moins en cours de modification afin de rajouter les addons sous forme de module. Mais bon, comme j'ai pas mal de Taf en cours, ça n'avance pas très vite ...
Si vous faites quelque chose, faites en sorte que ce soit universel, car au final, je voudrai que le pack le soit aussi.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#34

Message par Tlem » sam. 24 déc. 2011 11:00

Mise à jour du pack en version 2.2.0 :
  • - Mise à jour AutoIt v3.3.8.0.
    - Mise à jour de SandBoxie 3.62.0.0.


Il doit sans doute subsister le bug sur la mise à jour de SandBoxie.
Si vous ne voulez pas avoir de problème, désinstallez votre version de SandBoxie avant, ou décochez la case. ;)

Avatar du membre
sablier94
Niveau 4
Niveau 4
Messages : 87
Enregistré le : lun. 20 sept. 2010 09:18
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#35

Message par sablier94 » sam. 24 déc. 2011 11:23

Salut,

Merci pour la mise à jour du pack ! :)

Par contre quand je veux installer cette nouvelle version, il me demande si j'ai bien sauvegardé mes fichiers modifiés et paramètres personnels.

Que faudrait-il que je sauvegarde ?

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#36

Message par Tlem » sam. 24 déc. 2011 11:31

Hé bien les fichiers du dossier C:\Program Files\AutoIt3 que vous auriez ajoutés ou modifiés. ;)
La pack fait de lui même un backup des fichiers de config de base (si vous ne désactivez pas l'option), mais selon les utilisateurs, certains ajoutent des Includes personnalisés, un ou plusieurs add-on perso, etc ...

En général, celui qui à fait des modifs, il sait ce qu'il a fait, donc, qu'il pense à sauver son taf. ;)

Avatar du membre
sablier94
Niveau 4
Niveau 4
Messages : 87
Enregistré le : lun. 20 sept. 2010 09:18
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#37

Message par sablier94 » sam. 24 déc. 2011 11:35

Ok alors ce sera juste les includes pour moi.

Merci et joyeux noël ! :wink:

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#38

Message par Tlem » jeu. 05 janv. 2012 21:46

Mise à jour du pack en version 2.2.1 (Voir première page).
  • - Mise à jour Scite4AutoIt du 29-12-2011
    - Mise à jour du fichier locale.properties
    - Mise à jour de SciTEUser.properties pour conserver l'ancien thème
    - Déplacement de AutoItSecure vers le dossier Extras
Pour ceux qui souhaiteraient utiliser le nouveau thème, supprimez la dernière section du fichier SciTEUser.properties.
A partir de Scite4AutoIt, il suffit de cliquer le menu Options puis ouvrir fichier d'options utilisateur (si vous avez mis Scite4AutoIt en Français ;) )

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11312
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#39

Message par Tlem » dim. 22 janv. 2012 01:15

Mise à jour du pack en version 2.2.2 (Voir première page) pour corriger quelques bugs.
.

Avatar du membre
RL77LUC
Niveau 5
Niveau 5
Messages : 173
Enregistré le : mar. 21 sept. 2010 15:54
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#40

Message par RL77LUC » mar. 24 janv. 2012 20:06

Bonne nouvelle ! Je pensais que le pack avait été abandonné ... :oops:

Répondre