Autoit et Windows 10

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
Tibreizh
Niveau 1
Niveau 1
Messages : 2
Enregistré le : jeu. 17 oct. 2019 14:33
Status : Hors ligne

Autoit et Windows 10

#1

Message par Tibreizh » jeu. 17 oct. 2019 14:42

Bonjour,

Je suis tout nouveau sur le forum et j'utilise Autoit de temps en temps dans mon travail professionnel.

J'ai créé des fichiers au3 avec des instructions simples, telles que FileMove, Filecopy etc ...

FileMove(@UserProfileDir & "\Desktop\fichier.exe",@UserProfileDir & "\Documents\fichier.exe")

Sur Windows 7 c'est sans aucun problème mais si je prends le même script sur Windows 10 rien ne se passe (pas d'erreur non plus). J'avoue que pour la première fois je sèche durement et je viens donc vous trouver pour que vous puissiez peut être m'aiguiller vers une solution.

Il y a des conditions particulières pour utiliser Autoit sur des postes Windows 10 (des pré-requis ?) ?

Merci.

Tibreizh

Avatar du membre
mdanielm
Membre émérite
Membre émérite
Messages : 242
Enregistré le : mer. 11 déc. 2013 19:48
Status : Hors ligne

Re: Autoit et Windows 10

#2

Message par mdanielm » jeu. 17 oct. 2019 15:39

Bonjour,

1-Vérifier les attributs du fichier
2-Essayer de faire Copier-Coller avec la souris, sur le fichier. Si Windows 10 ne veut pas le faire, AutoIt n'est pas concerné.

Bon apprentissage.

Tibreizh
Niveau 1
Niveau 1
Messages : 2
Enregistré le : jeu. 17 oct. 2019 14:33
Status : Hors ligne

Re: Autoit et Windows 10

#3

Message par Tibreizh » jeu. 17 oct. 2019 15:44

Aucun souci pour les points 1 et 2.

Avatar du membre
mdanielm
Membre émérite
Membre émérite
Messages : 242
Enregistré le : mer. 11 déc. 2013 19:48
Status : Hors ligne

Re: Autoit et Windows 10

#4

Message par mdanielm » jeu. 17 oct. 2019 16:11

3- Essayer #RequireAdmin au début de votre code.

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 722
Enregistré le : ven. 12 août 2011 18:49
Localisation : Essonne
Status : Hors ligne

Re: Autoit et Windows 10

#5

Message par walkson » jeu. 17 oct. 2019 18:26

Bonjour,
une chose me chagrine, la destination @UserProfileDir & "\Documents\fichier.exe")
Il me semble qu'elle devrait être @UserProfileDir & "\Documents\
Et si problème persiste, contrôler les chemins avec Filexiste()
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi

Avatar du membre
DimVar
Niveau 10
Niveau 10
Messages : 835
Enregistré le : ven. 30 mai 2008 14:08
Status : Hors ligne

Re: Autoit et Windows 10

#6

Message par DimVar » mar. 22 oct. 2019 10:12

Bonjour Tibreizh,

@Walkson : Je ne vois pas d'erreur dans le filemove, on peut tout à fait définir un nom de fichier, même différent en destination (fait un rename du fichier dans la foulée).

@Tibreizh : Je pencherais aussi pour une histoire de droits. Dans tous les cas, pense à variabiliser le retour du filemove, et affiche le avec par exemple consoleWrite, pour savoir s'il est égal à 0 ou 1.
Ps : Il me semble que j'ai deja eu des soucis, où j'ai du lancer scite avec les droits admin pour le bon deroulement de mes scripts.

ex :
local $retrun
$retrun = FileMove(@UserProfileDir & "\Desktop\fichier.exe",@UserProfileDir & "\Documents\fichier.exe")
ConsoleWrite("$return = " & $retrun & @CRLF)
if $retrun = 1 Then
        ConsoleWrite("Filemove : Succes" & @CRLF)
Else
        ConsoleWrite("Filemove : Erreur" & @CRLF)
EndIf
 
N'évoquons pas la pierre, les jeunes risqueraient d'en poire !

Répondre