Erreur script depuis Màj windows

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
touslesmatins
Niveau 5
Niveau 5
Messages : 196
Enregistré le : dim. 15 févr. 2009 01:08
Status : Hors ligne

Erreur script depuis Màj windows

#1

Message par touslesmatins » mer. 23 janv. 2019 18:01

Bonjour à tous,

Je reviens vers vous après une longue absence…
J'ai mis au point un script qui fonctionne depuis quelques années. Depuis j'ai changé de PC et suis maintenant sur Win10 en x64 et je suis amené à perfectionner mon script et je rencontre un type d'erreur qui paralyse le bon fonctionnement du script.

POur faire simple, lorsque je clique sur un bouton, le script ouvrait une page html dédiée et depuis peu ce n'est plus le cas !!!
J'ai ce type d'erreur et le script se bloque….
Je n'ai qu'une solution pour que cela fonctionne c'est de redemarrer mon PC, ensuite cela fonctionne.
Suis je le seul dans ce cas ?
Merci d'avance pour votre aide.

>"C:\Program Files (x86)\AutoIt3\SciTE\..\autoit3.exe" /ErrorStdOut "C:\ooprint\OIPv3.au3"
--> IE.au3 T3.0-2 Warning from function _IEAttach, Cannot register internal error handler, cannot trap COM errors (Use _IEErrorHandlerRegister() to register a user error handler)
--> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch
### COM Error ! Number: 80040154 ScriptLine: 215 Description:
--> IE.au3 T3.0-2 Error from function _IECreate, (Browser Object Creation Failed)
--> IE.au3 T3.0-2 Error from function _IEBodyReadHTML, $_IESTATUS_InvalidDataType

touslesmatins
Niveau 5
Niveau 5
Messages : 196
Enregistré le : dim. 15 févr. 2009 01:08
Status : Hors ligne

Re: Erreur script depuis Màj windows

#2

Message par touslesmatins » ven. 25 janv. 2019 13:20

Bonjour,
Personne ne connait le meme probleme ?

Avatar du membre
TommyDDR
Modérateur
Modérateur
Messages : 1787
Enregistré le : mar. 22 juil. 2008 20:55
Localisation : Nantes
Status : Hors ligne

Re: Erreur script depuis Màj windows

#3

Message par TommyDDR » ven. 25 janv. 2019 13:31

Si vous ne fournissez pas un code simple reproduisant votre problème, vous n'aurez malheureusement pas beaucoup de réponse.
3.1415926535897932384626433832795028841971693993751058209749445923078164062862089986280348253421170679

touslesmatins
Niveau 5
Niveau 5
Messages : 196
Enregistré le : dim. 15 févr. 2009 01:08
Status : Hors ligne

Re: Erreur script depuis Màj windows  

#4

Message par touslesmatins » ven. 25 janv. 2019 15:14

Ah ok.
En fait, cette simple action, générait l'erreur mentionnée.
#include <IE.au3>
Local $oIE = _IECreate("www.autoitscript.com")


Elle fonctionnait une seule fois et ensuite lorsque je relançais le script cela ne fonctionnait plus !!!!!!!

Du coup après quelques recherches et tentatives, voici comment j'ai réglé mon problème ça peut servir aux autres….
J'ai forcé ce jour la mise à jour de Windows 10 + mise à jour ie11 et apres un redemarrage tout à été réglé.
Pourvu que ça dure, bonne journée àtous

Répondre