[R] Missing space before continuation character

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
jpascal
Niveau 4
Niveau 4
Messages : 99
Enregistré le : jeu. 16 oct. 2008 15:21
Status : Hors ligne

[R] Missing space before continuation character

#1

Message par jpascal » lun. 26 nov. 2018 15:32

Bonjour,

Je souhaite utiliser la méthode SpawnInstance_ mais l'underscore pose problème.

J'utilise Scite.

Test()

Func Test()
    Local $oWMIService = ObjGet("winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2")
    If NOT IsObj($oWMIService) Then Return SetError(1, 0, 0)
    Local $oPrinter = $oWMIService.Get("Win32_Printer").SpawnInstance_
    If NOT IsObj($oPrinter) Then Return SetError(1, 0, 0)
EndFunc

Comment puis-je faire fonctionner ce code ?
Modifié en dernier par jpascal le mer. 12 déc. 2018 19:05, modifié 3 fois.
AutoIt 3.3.15.1-1 / SciTE 4.1.0 / Windows 7 & 10 x64

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11326
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: [..] Missing space before continuation character

#2

Message par Tlem » jeu. 29 nov. 2018 23:13

Bonsoir.
Quel est le problème avec ce code ?
J'ai copier/coller celui-ci dans SciTE et je l'ai exécuté sans avoir la moindre erreur ...
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

jpascal
Niveau 4
Niveau 4
Messages : 99
Enregistré le : jeu. 16 oct. 2008 15:21
Status : Hors ligne

Re: [..] Missing space before continuation character

#3

Message par jpascal » mar. 04 déc. 2018 15:18

Bonjour,
"test.au3"(6,35) : error: Missing space before continuation character.
    Local $oPrinter = $oWMIService.Get("Win32_Printer").SpawnInstance_

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
AutoIt 3.3.15.1-1 / SciTE 4.1.0 / Windows 7 & 10 x64

Avatar du membre
orax
Modérateur
Modérateur
Messages : 1467
Enregistré le : lun. 23 mars 2009 04:50
Localisation : ::1
Contact :
Status : Hors ligne

Re: [..] Missing space before continuation character

#4

Message par orax » mar. 04 déc. 2018 15:27

Est-ce que tu utilises la version beta d'AutoIt ? J'utilise la version stable (3.3.14.5) et je n'ai pas d'erreur.
De petits détails peuvent faire toute la différence. — Quand la boule de neige commence à rouler… poussez-la. (Columbo)

jpascal
Niveau 4
Niveau 4
Messages : 99
Enregistré le : jeu. 16 oct. 2008 15:21
Status : Hors ligne

Re: [..] Missing space before continuation character

#5

Message par jpascal » jeu. 06 déc. 2018 09:46

Bonjour orax,

J'utilise la version 3.3.15.1 comme indiqué dans ma signature.

Je viens de m'apercevoir qu'il existait un correctif :
autoit-v3.3.15.1-1.zip 2018-10-05 17:54 18M

Il corrige le problème.

Désolé pour le dérangement.
AutoIt 3.3.15.1-1 / SciTE 4.1.0 / Windows 7 & 10 x64

Répondre