Utiliser plusieurs versions d'AutoIt pour compiler un script

Espace contenant des tutoriels divers concernant AutoIt.
Règles du forum
.

Tutoriel "La programmation avec Autoit" : https://openclassrooms.com/fr/courses/1 ... vec-autoit
Répondre
Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11313
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Utiliser plusieurs versions d'AutoIt pour compiler un script

#1

Message par Tlem » dim. 04 mars 2018 16:12

Bonjour, l'idée ici est de pouvoir continuer d'avoir la dernière version d'AutoIt, mais d'avoir la possibilité d'utiliser ou de compiler un script avec une autre version d'AutoIt.
Pour cela, rien de plus simple :
  1. Téléchargez la version "zip" ou "sfx.exe" d'AutoIt dont vous avez besoin sur ce lien.
    .
  2. Décompressez cette archive dans un sous dossier de votre installation d'AutoIt (ex : C:\Program Files (x86)\AutoIt3\3.2.12.1)
    .
  3. Pour finir, rajoutez dans l'entête de votre script la directive : #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.2.12.1

Avec une telle solution, on peux imaginer l'utilisation de plusieurs versions d'AutoIt en dé-commentant la version à utiliser :
;~ #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.8.1
#AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.2.12.1
;~ #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.14.2
;~#AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.14.3

;~Le reste du code AutoIt
Thierry

Rechercher sur le forum ----- Les règles du forum
Le "ça ne marche pas" est une conséquence commune découlant de beaucoup trop de raisons potentielles ...

Une idée ne peut pas appartenir à quelqu'un. (Albert Jacquard) tiré du documentaire "Copié n'est pas volé".

Répondre